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& (ampersand), 117
%$LET statement, 329

* (multiplier symbol), 58
$WINDOW statement, 334
3-D effect for graph, 152

o/ ] o

Access (Microsoft)
data management, 82-83
importing database from, with ODBC,
89-91
importing database from,
with OLE DB, 92
accessibility, 10
accessing. See also accessing data
information map, 346-347
OLAP cube, 246
stored processes using add-in, 276-277
accessing data
from add-in, 265-266
data set, opening, 25-27
diagnosing issues in, 305-311
Exchange E-Mail, 92
filtering data, 27-32
importing Excel workbook, 84-87
with OLE DB and ODBC, 88-92
from other documents, 92-93
overview of, 24-25, 81
server-based, 93-98
ActiveX graph format, 203
ad hoc analysis, 270-275
Add From Project dialog box, 52-53
Add Measure wizard, 257

Add New Parameter dialog box,
114, 115, 330
Add New Style dialog box, 205-206
Add Results window, 230
Add Tables button (Filter and Query
task), 51, 107-108
Add-In for Microsoft Office
accessing and managing data, 266-270
ad hoc analysis, 270-275
information map, 346-347
integration features, 265-266
Microsoft Excel example, 262-264
Office versions, 265
Option dialog box, 264-265
overview of, 15-16, 261-262
refreshing results, 279-281
sharing work, 281-282
star schema, 318
stored processes, 275-279
Adobe Acrobat Reader, 132, 293
Adobe Acrobat report, 131-133
Advanced Expression Editor window
with calculation partially complete, 58
with completed calculation, 59
computed columns, creating, 111
Microsoft Excel, 269
opening, 57, 113, 268
ALLOWXMD system option, 332
ampersand (&), 117
analysis of variance (ANOVA), 181-183
Analysis Services, 246
Analysis Tools, 263
analytics
ANOVA and regression, 181-184
assumptions, 174
categorical data analysis, 175-178
confidence interval, 173-174
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analytics (continued)
correlation analysis, 178-181
data mining, 185, 196-197
forecasting, 185, 193-195
multivariate analysis, 185, 191-193
overview of, 13-15, 171
p-values, 173, 179
quality control methods, 185, 188-190
resources on, 354
survival analysis, 185, 186-187
variability, 172
variance, 174
Analytics Platform, 300
Analyzec>ANOVA, 182
Analyzer>Capability Analysist>
Histograms, 189
Analyze=>Control Charts, 190
Analyze=>Multivariatem>Canonical
Correlation, 180
Analyzem>Multivariate>Cluster Analysis/
Discriminant Analysis, 192
Analyzer>Multivariatec>Correlations, 179
Analyze>Pareto Chart, 190
Analyze=>Regression, 183
Analyze=>Survival Analysis, 186
Analyze=>Time Series®>ARIMA Modeling
and Forecasting, 195
Analyzer>Time SeriestoBasic Forecasting,
74, 195
Analyze=>Time Series=>Create Time
Series Data, 195
Analyze=>Time Series=>Prepare Time
Series Data, 195
Analyze=>Time Series=>Regression
Analysis of Panel Data, 195
Analyze=>Time Series=>Regression
Analysis with Autoregressive
Errors, 195
ANOVA (analysis of variance), 181-183
Append Table task, 118
appending tables, 118-119
application settings, 22

Apply to Other Elements dialog box, 208
area plot, 158
ARIMA Modeling and Forecasting
task, 195
arranging SAS Report output, 231
arrow icons, 269
ascending order sort, 106
assembling report from various tasks
HTML Document Builder, 229-230
from SAS Report output, 231-233
selecting ingredients for, 228-229
Assign Library Wizard, 95-97, 307-311
assigning columns to use in report,
209-210
association, 177
assumptions, 174
auto-join feature, 54
average sale amount and total units sold
by subcategory bubble plot, 159

ol e

Back button, 249
baking in process for saving files,
223-226
bar chart, 153-154
Bar Chart task
with assigned roles, 34
with context-sensitive help, 33
running, 34-35
Basic Forecasting task, 73-77, 195
beer sales data set example, 74
bell-shaped curve, 121
BI Server, 261, 262
book, Web site for, 355
bookmarking, 256, 257
box and whisker plot, 72-73, 144
box plot
creating, 163-164, 165
description of, 159-160
Box Plot task, using with OLAP data, 255
Browse Available Fonts dialog box, 207
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bubble plot, 158, 159

built-in styles, 204

Business Intelligence, 136

Business Intelligence SAS Users
Group, 354

business rules, integration of, 315

oo

calculated measure, 256, 257
Candy Sales Summary data set example,
27, 31
canonical correlation, 180
Cartesian Product, 53
categorical data analysis, 175-178
Categorical Data Analysis,
application of, 14
categorical variable, 175
cause, 157
Change Slicer dialog box, 250
changing input data source for task,
338-339
channel, distributing information
through, 227-228
Characterize Data task, reporting
features, 138, 143
Characterize Data task wizard, 70-71
chart footnotes, removing, 44
charts. See also graphs
bar, 33-35
control, 190, 191
donut, 160
footnotes to, removing, 44
grouped pie, 154
horizontal bar, 153
Pareto, 190
pie, 154, 155
radar, 161-162
resources on, 354
stacked pie, 154
Choose Location dialog box, 274
clicking and dragging, 232

Client tier, 302
closing. See also opening
Filter and Query task, 31
SAS Enterprise Guide, 45
Cluster Analysis task, 192
collapsing data in OLAP, 247
Column Options pane (Import Data
dialog box), 86
columns of data. See also computed
columns
assigning, to use in report, 209-210
recoding, 106
selecting, 105
splitting, 120
stacking, 120
comma-delimited file, 83
Compare Data task, 121
comparing data, 121
complex join, 101
composite report, creating, 41-46
Compress All Files check box (Send
window), 225
computed columns
creating, 57-60, 105
formatting, 60-64
Computed Columns dialog box, 112
conditional formatting, 257, 258
confidence interval, 173-174
configuring
e-mail system, 224
logging activity for servers, 351
contingency table, 176-177
contour plot, 160-161
control chart, 190, 191
controlled experiment, 179
conversion of data, 83
copying data
from Excel to SAS server, 270-271
SAS Enterprise Guide, 306
from server to server, 339
size of source, 83
correlation analysis, 178-181

359
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correlation of sales amount
with discount given
scatter plot, 157
Correlation task, 179
Create Format task, 119
Create New SAS Stored Process Wizard
Execution Environment window, 237
General Information window, 235
Librefs window, 238
Metadata Location window, 237
Output Options and Input Streams
window, 239, 240
overview of, 235
Parameters window, 238-239
SAS Code window, 236
Summary window, 240
Create Time Series Data task, 195
cross-sectional analysis, 195
cross-tabular summary, 176-177
cross-tabulation report, 292
Ctrl+click (select multiple items), 51
Ctrl+M (Maximize Workspace), 35, 337
cube
accessing, 246
description of, 244
example of, 245
Cube Explorer, 253-254
Cube View Manager, 246, 247
Custom Calculation, 257
custom task, developing, 340
customizing
SAS Enterprise Guide interface, 22
styles, 205-208

o) e

data. See also accessing data; copying
data; data management; data
warehousing; summarizing data
conversion of, 83
expanding in OLAP, 247, 251, 252
filtering, 27-32, 245, 249-250, 251
historical, and forecasting, 194

joining, 50-56
reducing volume of, 122-123
from SAS server, opening directly into
Excel, 263
scoring, 196-197
storing, 82, 244
subsetting, 140
temporary, 220
transforming, 178, 221-222
Web Report Studio, 288-289
data filter for report, selecting, 286
data grid view, disabling automatic
opening of, 340-341
Data Integration Server, 12
data items for report, selecting, 285
data listing, 139
data management
from add-in, 265-266
appending tables, 118-119
comparing data, 121
data set, opening, 25-27
deleting data sets and formats, 122
editing data table values, 118
example using common tasks, 122-127
Excel, Access, and text files, 82-83
filtering data, 27-32, 245, 249-250, 251
formats, creating, 119
options for, 99-100
overview of, 24-25
ranking variables, 121
selecting random sample of data, 120
sorting data, 119
splitting columns, 120
stacking columns, 120
standardizing data, 121
summarizing data set attributes, 121
transposing data, 119-120, 123-126
data mart, 318-319
data mining
application of, 14
description of, 185, 196
Model Scoring task, 196-197
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data preparation
for forecasting, 195
for line plot, 164-166
overview of, 10-12
data set
deleting, 122
description of, 93
indexed, 93
opening, 25-27
renaming, 56
summarizing attributes, 121
Data Set Attributes task, 121
data source, defining, 306
data storage, 82
data summaries and reporting, 12-13
data table values, editing, 118
Data tier, 303
Data Tools, 263
Data Value Properties dialog box, 38, 213
data warehousing
characteristics of, 315-316
data mart compared to, 318-319
need for, 313-314
overview of, 313
principles of, 316-318
uses of, 314-315
Datac>Append Table, 118
database engine, 308
database user ID, 309
DatacoFilter and Query, 28
DataroRead Only, 118
Datar>Sort Data, 119
Datac®Wizards=>Summary Tables, 146
date, storage of, 165
DDE (Dynamic Data Exchange), 332-333
decile, 121
default view of SAS Enterprise Guide
interface, 21
defining
data source, 306
library, 95
Delete Data Sets and Formats task, 122

dendrogram, 192
dependent variable, 157
deployment variable, 300
descending order sort, 106
DescribervCharacterize Data, 70
Describem>Distribution Analysis, 175
Describer>List Data, 139
Describer>Summary Statistics, 72
Describer>Summary Tables, 36
Describe>Wizards=>Summary
Statistics, 144
designing report, 232
destination type, 200
developing custom task, 340
diagnosing data access issues, 305-311
dichotomous variables, 177
differences, test for, 177
dimension, 244
dimension table, 55, 317
disabling
administrative capabilities of SAS
Enterprise Guide Explorer, 345-346
automatic opening of data grid view,
340-341
Discriminant Analysis task, 192
distributed computing
metadata, 303-304
overview of, 301-302
tiers, 302-303
distributing information through
channel, 227-228
Distribution Analysis task, 66, 175
DM Review (online magazine), 354
Document Builder window, 230
donut chart, 160
Download SAS Data task, 339
dragging and dropping, 232
drilling down and up in OLAP,
246-247, 251, 252, 258
Dynamic Data Exchange (DDE), 332-333
dynamic report, 41
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Edit Filter dialog box, 30
Edit Parameter Definition dialog box,
115,116
Edit Report Contents dialog box
with charts and summary table, 43
new report, creating, 231
Report Editor, 137, 138
summary tables, 42
editing data table values, 118
effect, 157
EGDefault style, 201
. egp file extension, 219
e-mail system, configuring, 224
e-mailing report automatically, 224-226
enabling formatting in wizard, 148-149
ENDSAS statement, 334
engine
selecting for library, 308
XML, 94
Enterprise Bl Server, 261, 262
Enterprise Data Integration Server, 316
Enterprise Guide. See also Filter and
Query task
accessing data, 82-93
Basic Forecasting task, 73-77
capabilities of, 20
changing on-screen view, 22-24
charting capabilities, 33-35
closing, 45
copying data, 306
data access and management options,
24-32
data management, 12
development of, 19
documentation, 353
Expression Builder, 105
importing files, 83
libraries, 48-49
productivity, 322
reporting features, 36-46, 129-131

Sample Data directory, 107
SAS Tasks, 28
as Six-Minute Abs of SAS, 47
storing data, 82
summarizing data, options for, 64-69
Summary Statistics task, 70-73
Undo Apply button, 208
using first time, 20-22
using to run SAS programs, 219-220
versions of, 20
Enterprise Guide Explorer
disabling administrative capabilities of,
345-346
managing logins from, 344-345
Enterprise Miner, 196
ESRI ArcGIS software, 251, 253
Excel (Microsoft)
data management, 82-83
exporting data to, 293-294
exporting results to, 221-223
importing workbook from, 84-87
opening data from SAS server directly
into, 263
opening data with add-in, 266-269
pivot table, 271-272
SAS menu in, 263-264
SAS toolbars in, 262-263
spreadsheet hell, 275-276
transferring data to SAS server, 270-271
exception rule, 215
Exchange E-Mail, 92
Execution Environment window (Create
New SAS Stored Procedure
Wizard), 237
expanding data in OLAP, 247, 251, 252
explicit link, building, 323-324
Export filename To window, 221
EXPORT procedure, 222
exporting
baking in process for saving file before,
223-226
data to Microsoft Excel, 293-294
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HTML format, 135

results, 221-223

SAS Report format, 136
Expression Builder, 105
external styles, 205

ofF e

F3 (submit program for processing), 337
F4 (process flow view), 337
fact table, 55, 317
fair, meaning of, 172
features

analytics, 13-15

data preparation, 10-12

data summaries and reporting, 12-13
file output type, changing, 130-131
file-based engine, 308
File=>Exit, 45
FilemExport, 221
FilewImport Data, 84
Filec>Manage Logins, 345
FilewoNewr>Report, 231
File>Openc>Data, 25, 310
Filec>Open>ODBC, 89
Filec>Open>OLAP Cube, 246
Filec>Open>Other, 92
Filec>Open>SAS Servers, 95
Filec>Print Preview, 44, 45
FilecoPublish to Channels, 227
Filec>Save Project As, 44-45
FilewSend To=>E-Mail Recipient as a Step

in Project, 224

Filter and Query task

Add Tables button, 51, 107-108

add-in, 272

closing, 31

computed columns, creating, 57-60, 105

data management, 100-101

Data menu, 65

filtering data, 27-32

filtering table data, 104
formatting computed columns, 60-64
joining table data, 101-104
listing three tables, 110
parameterizing, 106-117
recoding columns, 106
selecting specific columns of data, 105
sorting data, 106
uses of, 49-50
with variables selected, 55
Filter and Query task dialog box
opening, 28, 29
Select Data space, 28, 29
Filter Data tab (main task window), 104
filtering data
with Filter and Query task, 27-32
OLAP, 245, 249-250, 251
filtering table data, 104
flexibility, 10
fonts and HTML, 209
footnotes to chart, removing, 44
forcing task to generate different output
than normal, 130
Forecast Server, 273, 300
Forecast Stored Process dialog box, 277
forecasting
application of, 14
Basic Forecasting task, 73-77, 195
complexity of, 73
description of, 185, 193-194
preparing data for, 195
foreign key, 317
format, deleting, 122
format mask, creating, 119
FORMAT procedure, 215
Formats dialog box, 62-63, 113
formatting. See also formatting report
computed columns, 60-64
conditional, 257
enabling in wizard, 148-149
sales report, 141-142
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formatting report
custom styles, 205-208
graph styles, 202-203
overview of, 199
styles, 200, 201-202
tabular report, 209-215

full outer join, 103-104

oG o

General Information window (Create
New SAS Stored Procedure
Wizard), 235

Generalized Linear Models, 183

geographic data in map graph, 163, 251

Get Values button (Values selection
dialog box), 30

Goodnight, Jim (founder of SAS
Institute), 2, 9, 19

graph styles, 202-203

Graph~Box Plot, 164

graphical summary, creating, 116-117

Graphr>Line Plot, 167

graphs

adding to summary table report, 41-46
area plots, 158

bar charts, 153-154

box and whisker plots, 72-73, 144
box plots, 159-160, 163-164, 165
bubble plots, 158, 159

contour plots, 160-161

conveying message with, 151-152
creating, 163-168

donut charts, 160

hi-lo or hi-lo-close plots, 159
histograms, 144, 188-189

in HTML format, 135

line plots, 154, 155-156, 164-168
map graphs, 162, 163, 250-253
OLAP Analyzer, 250-253
overview of, 151

pie charts, 154, 155

radar charts, 161-162

resources on, 354

scatter plots, 157

shown with table, 252

summary table compared to, 152

3-D effect for, 152

Web Report Studio, 290
Graph>Wizards=>Bar Chart, 116
gross sales by region

area plot, 158

line plot, 155, 168

line plot adjusted to eliminate scaling

effect, 156

group breaks for report, specifying, 286
grouped pie charts, 154

o/ o

handle, 232
Header & Footer dialog box, Titles &
Footnotes tab, 44
Heading Properties for ALL dialog
box, 214
Heading Properties for Subcategory
dialog box, 39
Heading Properties for Sum dialog
box, 212
headless, 333
Help option (SAS menu), 263
Help=>About SAS Enterprise Guide, 301
Help=>SAS Enterprise Guide Help, 92
High Performance Forecasting,
application of, 15
hi-lo or hi-lo-close plot, 159
histogram
description of, 144
as quality control method, 188-189
historical data and forecasting, 194
history of SAS software, 9
horizontal bar chart, 153
HTML Document Builder, 135, 229-230
HTML (HyperText Markup Language)
description of, 130
ODS, 200, 202
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HTML (HyperText Markup Language)
report
description of, 134-135
fonts, 209
using for mix report, 229

o]e
IBM z/08, 300, 344
image formats, 203
Impact Analysis data, 281
implicit pass-through, 347-348
implicit relationship, 323
Import Data dialog box
Column Options pane, 86
Region to Import pane, 85
importing
Access database with ODBC, 89
Access database with OLE DB, 92
Excel workbook, 84-87
files, 83
independent variable, 157
indexed data set, 93
Information Delivery Portal, 16, 227-228
information map, 284, 346-347
Information Map Studio, 17
Inmon, Bill (founder of data
warehousing), 315-316
inner join, 102
input data source for task, changing,
338-339
installation, specifications and ease of,
299-300
interaction
predictive variables, 180
Web Report Studio, 289
interactive map, 292
interface for SAS Enterprise Guide
customizing, 22-24
default view, 21
reverting to default layout, 24
IT professional, 17
iteration, 326

o]o

Java graph format, 203
joining

table data, 101-104

three sample tables, 107-114
joining data

from multiple tables, 51-56

simple two-table join, 50

oK o

key, 101
keyboard shortcuts
Ctrl+click (select multiple items), 51
Ctrl+M (Maximize Workspace), 35, 337
F3 (submit program for
processing), 337
F4 (process flow view), 337
Shift+click (select contiguous block), 51
killing SAS process, 349
Kirk, Herb (executive), 9

o/ o

layout of report, 232
Learning Edition, 20, 302
left join, 102-103
$LET statement, 329
levels within dimension, 244
library
creating for project, 95-97, 306-311
defining, 95
description of, 48-49
link from task to first reference of,
creating, 311
SASUSER, 48, 343-344
temporary data, 220
updating Process flow to assign, 98
WORK, 48, 220
library engine, 308
Library Wizard dialog boxes, 95-96, 97
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Librefs window (Create New SAS Stored
Procedure Wizard), 238
Life Tables task, 186-187
line plot
creating, 164-168
description of, 154, 155-156
Linear Models, 182
Linear Models dialog box, 273
Linear Regression, 183, 184
link
from data table to SAS program,
building, 323-324
from task to first reference of library,
creating, 311
Linux, 300
List Data task
Describe menu, 66
reporting features, 138, 139-142
listing report, 215-216. See also plain text
local-local setup, 300-301
location for stored process, specifying,
236-237
Login Manager window, 345
login, managing, 344-345
Logistic Regression, 183
lognormal distribution, 175, 176

ol o

macro variable, 117
main task window
Filter Data tab, 104
Parameters button, 107
Select Data tab, 105
Management Console, 17, 303
managing data
from add-in, 265-266
appending tables, 118-119
comparing data, 121
data set, opening, 25-27
deleting data sets and formats, 122
editing data table values, 118
example using common tasks, 122-127

Excel, Access, and text files, 82-83
filtering data, 27-32, 245, 249-250, 251
formats, creating, 119
options for, 99-100
overview of, 24-25
ranking variables, 121
selecting random sample of data, 120
sorting data, 119
splitting columns, 120
stacking columns, 120
standardizing data, 121
summarizing data set attributes, 121
transposing data, 119-120
managing login, 344-345
map graph
description of, 162, 163
OLAP Analyzer, 250-253
Maximize Workspace toolbar icon,
35, 337
MDX editor, 257, 258-259
MDX (MultiDimensional Expression), 258
Mean Individual Measurement chart,
190, 191
mean plots of strength by type, 274-275
mean sales by region line plot, 168
measure, 244
member isolation, 248
member property, 258
message, conveying with graph, 151-152
metadata configuration, 304
Metadata Location window (Create New
SAS Stored Procedure Wizard), 237
Metadata Server, 17, 303-304
Metadata Server log, 350
metadata, synchronizing with reality, 346
Metadata tier, 302
METALIB procedure, 346
Microsoft Access
data management, 82-83
importing database from, with ODBC,
89-91
importing database from,
with OLE DB, 92
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Microsoft Excel
data management, 82-83
exporting data to, 293-294
exporting results to, 221-223
importing workbook from, 84-87
opening data from SAS server directly
into, 263
opening data with add-in, 266-269
pivot table, 271-272
SAS menu in, 263-264
SAS toolbars in, 262-263
spreadsheet hell, 275-276
transferring data to SAS server, 270-271
Microsoft Office Add-In
accessing and managing data, 266-270
ad hoc analysis, 270-275
information map, 346-347
integration features, 265-266
Microsoft Excel example, 262-264
Office versions, 265
Option dialog box, 264-265
overview of, 15-16, 261-262
refreshing results, 279-281
sharing work, 281-282
star schema, 318
stored processes, 275-279
Microsoft PowerPoint
add-in, 265
output of SAS Tasks, 275
stored processes, 277, 278
Microsoft Windows, 300
Microsoft Word
add-in, 265
output of SAS Tasks, 275
stored processes, 277, 279
mix report
HTML Document Builder, 229-230
from SAS Report output, 231-233
selecting ingredients for, 228-229
Mixed Models, 14, 182
Model Scoring task, 196-197

Modify Data Source dialog box,
267, 268, 272
Modify Join dialog box, 110
Modify option (SAS menu), 263
Modify Repository window, 304
MultiDimensional Expression (MDX), 258
multiplier symbol (*), 58
multivariate analysis
cluster and discriminant analyses,
192-193
description of, 185, 192
principal component analysis, 192
My Styles, 205

o\ o
naming. See also renaming
library, 307
stored process, 236
New Worksheet button (Choose Location
dialog box), 274
“The New Yankee Workshop”
(TV show), 322
Newr>Build Expression, 57
nominal variable, 175
Nonlinear Regression, 183
Nonparametric ANOVA, 182
normal distribution, 121, 175
ntile, 121
numeric variables, summarizing specific,
71-73

o () o

Object Linking and Embedding for
Databases (OLE DB), 88, 92

object spawner log, 350

ODBC Microsoft Access Setup dialog
box, 90

ODBC (Open Database Connectivity),
88-91

ODS (Output Delivery System), 200, 204
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OLAP Cube Studio, 244
OLAP. See On-Line Analytic Processing
OLAP Server, 244
OLAP server, 94
OLE DB (Object Linking and Embedding
for Databases), 88, 92
One Way ANOVA, 182, 183
One Way Frequencies task (Describe
menu), 68
On-Line Analytic Processing (OLAP)
bookmarking, 257
calculated measures, 257
conditional formatting, 258
data stored in, 244
description of, 15, 16, 243
drilling down and up, 246-247, 258
features of, 245, 256-259
filtering data, 249-250, 251
graphs and maps, 250-253
MDX editor, 258-259
member isolation, 248
member properties, 258
percentages, 253-254
speed of, 245, 271-272
table interaction, 246
using tasks with, 255-256
variance, 256
Open Data dialog box
importing, 84
joining, 51, 52
Open Data Source dialog box, 266-267
Open Database Connectivity (ODBC),
88-91
Open dialog box, 25, 26
Open From SAS Servers dialog box, 95
Open into PivotTable dialog box, 271
Open Tables dialog box
importing Access database
with ODBC, 91
importing Excel workbook, 84-85

opening. See also closing
Advanced Expression Editor window,
57, 113, 268
bookmark, 257
data from SAS server directly into
Excel, 263
data set, 25-27
data with add-in, 266-269
Filter and Query task dialog box, 28, 29
multiple sessions, 338
project, 46
report, 291
Options dialog box (Add-In for Microsoft
Office), 264-265
Options option (SAS menu), 263
ordered list, creating, 324-326
Ordered List window, 325
ordinal variable, 175
outlier, 72
output data set, renaming, 56
Output Delivery System (ODS), 200, 204
Output Options and Input Streams
window (Create New SAS Stored
Procedure Wizard), 239, 240
output type, changing, 130-131

oo

pane, pinning and unpinning, 24
parameterizing Query filter
multi-part example Part I, 107-114
multi-part example Part I, 114-116
multi-part example Part III, 116-117
overview of, 106-107
Parameters button (main task
window), 107
Parameters window (Create New SAS
Stored Procedure Wizard), 238-239
Pareto chart, 190, 191
path-based engine, 308
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PC SAS, 20
PDF (Portable Document File)
converting Web page to before
printing, 293
description of, 130
ODSs, 200
PDF (Portable Document File) report,
131-133
Pearson correlation, 179-180
percentages, working with, 253-254
performance and data warehousing, 315
Performance Warning dialog box, 89
petabyte, 318
pie chart, 154, 155
pinning pane, 24
pivot table, 271-272
plain text
advantages of, 215-216
description of, 130
example of, 131
Portable Document File (PDF)
converting Web page to before
printing, 293
description of, 130
ODSs, 200
Portable Document File (PDF) report,
131-133
PowerPoint (Microsoft)
add-in, 265
output of SAS Tasks, 275
stored processes, 277, 278
predictive variable, 194
Prepare Time Series Data tasks, 195
Preview window, Results tab, 87
Principal Components task, 192
Print Preview mode, 44, 45
PRINT procedure, 215
printer style, 202
printing and Web Report Studio, 293
probability plot, 190
PROC EXPORT procedure, 222

Process Explorer tool (Sysinternals),
349-350
process flow view, 32, 322-323
product category summary, creating, 144
product sales ranking by year report, 127
productivity, 322
programmer, 321-322
programming language, 2
project. See also project file
creating library for, 95-97, 306-311
opening, 46
scheduling, 341
Project Designer toolbar button, 32
Project Explorer, 32
project file. See also project
baking in process for saving files,
223-226
description of, 219
ordered list, creating, 324-326
organizing work into, 322-323
process flow view, 322-323
relationships in, 322-324
temporary data, 220
project log, 326-327, 339
project parameters, 329-332
prompted report, 239
Properties dialog box, 59-60, 112
Proportional Hazards task, 186-187
Publish window, 227, 281, 282
publishing report, 348
p-value, 173, 179

OQ.

Q-Q plot, 190
Quality Control, application of, 15
quality control methods
control charts, 190, 191
description of, 185, 188
histograms, 188-189
Pareto charts, 190, 191
Q-Q and probability plots, 190
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quarterly sales summary data set
example, 64
Query Builder
implicit pass-through, 347-348
parameters, 331
query, parameterizing, using product
column, 114-116
quintile, 121

o R o

radar chart, 161-162
Random Sample task, 120, 122-123
Rank task
Data menu, 65
options, 125-126
transforming data, 178
variables, 121
ranking variables, 121
read-only library, 48
rearranging table layout in Tables and
Joins dialog box, 55
recipe, 229
recipient for e-mail, specifying, 226
recoding columns, 106
reducing volume of data, 122-123
Refresh and Refresh Multiple options
(SAS menu), 263
refreshing results, 279-281
Region to Import pane (Import Data
dialog box), 85
Regional Sales Summary composite
report example, 43
regional sales summary report
example, 40
regression analysis, 181-184
Regression Analysis of Panel Data
task, 195

Regression Analysis with Autoregressive

Errors task, 195
regression line, 157
relational database, 94

Relative Contribution Analysis, 257
removing chart footnotes, 44
renaming. See also naming
output data set, 56
variable, 56
report. See also mix report; report
formatting; reporting features;
reporting options
Adobe Acrobat, 131-133

assembling from various tasks, 228-233

assigning columns to use in, 209-210
composite, creating, 41-46

creating in Web Report Studio, 284-288

cross-tabulation, 292
data filter for, selecting, 286
data items for, selecting, 205
designing, 232
dynamic, 41
e-mailing automatically, 224-226
group breaks for, specifying, 286
HTML, 134-135, 209, 229
layout of, 232
listing, 215-216
opening in Web Report Studio, 291
PDF, 131-133
prompted, 239
publishing, 348
RTF, 133-134
scheduling, 294-295
securing, 293
summary, creating, 126-127
summary table, 36-46, 146-148
tabular, 209-215
Report Editor, 137-138
report formatting
custom styles, 205-208
graph styles, 202-203
overview of, 199
styles, 200, 201-202
tabular report, 209-215
REPORT procedure, 215
Report Wizard, 284-288
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reporting features
Characterize Data task, 138, 143
graph, adding to summary table report,
41-46
List Data task, 138, 139-142
overview of, 129-131
Summary Statistics task, 138, 143-144
summary table report, 36-40
Summary Tables task, 138, 145-149
reporting options
changing, 130-131
HTML format, 134-135
PDF, 131-133
plain text, 131
RTF, 133-134
SAS Report format, 136-138
ReportoNew Using Wizard, 284
Report>Open, 291
Reports dialog box, 276, 277
Report>Schedule, 294
resizing item, 232
reverting to default layout, 24
right join, 103
R-Square, 182
RTF (Rich Text Format)
description of, 130
ODSs, 200
RTF (Rich Text Format) report, 133-134
running
SAS programs with SAS Enterprise
Guide, 219-220
stored process, 241
subset of tasks in project in sequence,
324-326

oS e

sales
by region bar chart, 153
by store and hour of day contour
plot, 161
by subcategory box plot, 160, 165
sales report listing, creating, 139-142

sales summary
ranked by year across products, 126
transposed by year, 125
Sall, John (executive), 9
Sample Data directory, 107
sansprinter style, 205
SAP BW, 246
SAS Analysis Tools, 263
SAS Analytics Platform, 300
SAS BI Server, 261, 262
SAS Business Intelligence, 136
SAS Code window (Create New SAS
Stored Procedure Wizard), 236
SAS Data Integration Server, 12
SAS Data Tools, 263
SAS Enterprise BI Server, 261, 262
SAS Enterprise Data Integration
Server, 316
SAS Enterprise Guide. See also Filter and
Query task
accessing data, 82-93
Basic Forecasting task, 73-77
capabilities of, 20
changing on-screen view, 22-24
charting capabilities, 33-35
closing, 45
copying data, 306
data access and management options,
24-32
data management, 12
development of, 19
documentation, 353
Expression Builder, 105
importing files, 83
libraries, 48-49
productivity, 322
reporting features, 36-46, 129-131
Sample Data directory, 107
SAS Tasks, 28
storing data, 82
summarizing data, options for, 64—-69
Summary Statistics task, 70-73
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SAS Enterprise Guide (continued)
Undo Apply button, 208
using first time, 20-22
using to run SAS programs, 219-220
versions of, 20
SAS Enterprise Guide Explorer
disabling administrative capabilities of,
345-346
managing logins from, 344-345
SAS Enterprise Miner, 196
SAS Favorites option (SAS menu), 263
SAS Forecast Server, 273, 300
SAS Information Delivery Portal, 227-228
SAS Institute Inc., 2
SAS Learning Edition, 20, 302
SAS Management Console, 303
SAS menu, 263-264
SAS Metadata Server, 303-304
SAS Metadata Server log, 350
SAS 9 deployment and RSASUSER system
option, 344
SAS object spawner log, 350
SAS OLAP, 94
SAS OLAP Cube Studio, 244
SAS OLAP Server, 244
SAS Report format
arranging output, 231-233
description of, 130, 136-138
ODSs, 200
using for mix report, 229
SAS server tier, 302
SAS Tasks. See also specific tasks
overview of, 28, 327
using from add-in, 272-275
SAS view, 93
SAS workspace server log, 350
SAS/ACCESS products, 306
SAS/ACCESS to PC File Formats product
module, 222
SAS=>Active Data=>Copy to SAS
Server, 270

SAS/AF, 333-334

SASc>Analyze Data, 273

SASc>Analyze Datac>pANOVA=>Linear
Models Task, 273

SAS.EXE process, 349-350

SAS=>Modify, 279

SAS=>Open Data Source=Into
PivotTables, 271

SAS=>Open Data Source=Into
Worksheet, 266

SAS=>Properties, 280

SAS=>Refresh, 279

SASc>Refresh Multiple, 280

SAS>Reports, 276

SAS=>Tools=>Publish, 281

SAS=>Tools=>Server Connections, 264

SASUSER library, 48, 343-344

sasweb style, 202

Save As dialog box, 44-45, 46

saving file, baking in process for, 223-226

Scalable Performance Data Engine
(SPDE), 94

scaling effect, 156

scatter plot, 157

Schedule Report dialog box, 294-295

scheduling

project, 341
report, 294-295

scoring data, 196-197

screenshot, setting interface to look like,
22-24

Seaside style, 202-203

securing report, 293

Select Analysis Variables and Statistics
screen (Summary Tables
Wizard), 147

Select Classification Variables screen
(Summary Tables Wizard), 147

select contiguous block (Shift+click), 51

Select Data Source dialog box, 89

Select Data tab (main task window), 105
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selecting
columns of data, 105
ingredients for mix report, 228-229
multiple items, 51
random sample of data, 120
type of graph to use, 151
Send window, 224-226
server
configuring and turning on logging
for, 351
selecting for library, 308
server log, 350-351
server tier, 302
server-based data, accessing, 93-94
sessions
catching and killing runaway, 349
opening multiple, 338
setup
distributed computing, 301-304
local-local, 300-301
sharing work, 281-282
Shewhart chart, 190
Shift+click (select contiguous block), 51
shortcut keys
Ctrl+click (select multiple items), 51
Ctrl+M (Maximize Workspace), 35, 337
F3 (submit program for
processing), 337
F4 (process flow view), 337
Shift+click (select contiguous block), 51
simple join, 101
size of data source, 81, 83, 88
sizing item, 232
Slicer tool (OLAP viewer), 249-250, 251
slicing data, 245, 249-250, 251
Sort Data task, 119
sorting data, 106, 119
SPDE (Scalable Performance Data
Engine), 94
Split Columns task, 120
splitting columns, 120

spreadsheet hell, 15
Stack Columns task, 120
stacked pie charts, 154
stacking columns, 120
standard pie chart, 154
Standardize Data task, 121, 178
standardizing data, 121
star schema, 317-318
statement, inserting within task, 327-328
static image type, 203
statistical significance, 173
statistics, resources on, 354
stored process
in add-in, 263, 275-279
creating, 235-240
example of, 234-235
overview of, 233-234
running, 241
storing data
in OLAP, 244
SAS Enterprise Guide, 82
strata, 186
Style Editor screen, 206
Style Manager screen, 205
style template, 204
styles
built-in, 204
customizing, 205-208
external, 205
graph, 202-203
My Styles, 205
report, 200, 201-202
submitting subset of program, 340
subsetting data, 140
success stories, 18
summarizing data
graphical summary, creating, 116-117
overview of, 12-13, 64-71
specific numeric variables, 71-73
summarizing data set attributes, 121
summary report, creating, 126-127

373
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Summary Statistics task
Describe menu, 66
reporting features, 138, 143-144
statement, inserting within task,
327-328
Task Roles pane, 72
using, 70-73
summary table, graph compared to, 152
summary table report
adding graph to, 41-46
creating, 36-40, 146-148
Summary Tables task
completed, 39
composite report, 41
reporting features, 138, 145-149
with roles assigned, 37
with table layout, 37
Summary window (Create New SAS
Stored Procedure Wizard), 240
support Web site, 5
survival analysis, 14, 185
switching libraries, 95
synchronizing metadata with reality, 346
Sysinternals Process Explorer tool,
349-350
SYSTASK function, 332

oJ e

t test, 182

Table Analysis task
contingency tables, 176-177
Describe menu, 68
statistics available from, 177

table data
filtering, 104
joining, 101-104

tables
appending, 118-119
contingency, 176-177
description of, 244

dimension/fact, 55, 317
pivot, 271-272
rearranging layout in Tables and Joins
dialog box, 55
shown with graph, 252
Web Report Studio, 290
Tables and Joins dialog box
with joins added, 54
parameterizing example, 109
rearranging table layout in, 55
with tables joined, 109
tabular report, formatting, 209-215
TABULATE procedure, 209-215
task list, 21
Task Status pane, 21
task status window, 349
temporary data, 220
testing library, 309-310
text file
description of, 94
sample of, 132
viewing, 130
text mining, 15
3-D effect for graph, 152
tier, 302-303
toggling toolbars, 22
toolbars
SAS, in Excel, 262-263
toggling, 22
Tools option (SAS menu), 263
Tools=>Assign Library, 95, 307
Tools=>Create HTML Document,
135, 229
Tools=>Create Ordered List, 325
Tools=>Options, 22
Tools=>Options>Results General,
130, 201
Tools=>Parameters (Macro Variable)
Manager, 329
Tools=>SAS Enterprise Guide
Explorer, 345



Tools>Schedule Project, 341
Tools=>Style Manager, 205
Top Customers Sales report, 292
transferring Excel data to SAS server,
270-271

transforming data

Standardize Data task, 178

when exporting, 221-222
Transpose Data task, 119-120, 123-126
transposing data, 119-120, 123-126
trend, 177
turning on logging for servers, 351
two-table join, 50
two-way contingency table, 176-177

o lf o

Undo Apply button (SAS Enterprise
Guide), 208

undo feature, 249

UNIX, 300

unpinning pane, 24

Upload SAS Data task, 339

usage permission, 293

User Code window, 328

user role, 293

oV

Values selection dialog box (Get Values
button), 30

variability, 172

variables
dependent, 157
dichotomous, 177
independent, 157
macro, 117
nominal, 175
numeric, 71-73
ordinal, 175
predictive, 194

ranking, 121
renaming, 56
types of, 175
variance, 174, 256
vertical (y) axis
bar chart, 153
dependent variable, 157
line plot, 156
viewing
HTML file, 135
PDF, 132
process flow, 32
products installed on server, 338
project log, 339
RTF file, 134
text file, 130
View=>Project Log, 327, 339
View=>Task Status, 349
View=>Toolbars, 22
volume of data, reducing, 122-123

o ([ o

warning message
for data sources, 89
when joining multiple tables, 53
Web middle tier, 303
Web Report Studio
advanced report-editing interface,
288-290
description of, 16, 17, 283
exporting data to Microsoft Excel,
293-294
opening report, 291
printing, 293
report, creating, 284-288
report examples, 291-292
scheduling reports, 294-295
securing reports, 293
star schema, 318
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Web sites
for book, 355
resources, 354-355
SAS Enterprise Guide documentation, 353
SAS success stories, 18
SAS support, 5
support, 353
Welcome to SAS Enterprise Guide dialog
box, 23
$WINDOW statement, 334
Windows (Microsoft), 300
wizard, enabling formatting in, 148-149
“The Woodwright’s Shop”
(TV show), 322
Word (Microsoft)
add-in, 265
output of SAS Tasks, 275
stored processes, 277, 279
WordPad, 133
WORK library, 48, 220

workflow presentation panes, 21
workspace

customizing, 22-24

default, 21

reverting to default layout, 24
workspace server log, 350

o X o
x axis, 157

X statement, 332
XML engine, 94

° y °
y (vertical) axis
bar chart, 153

dependent variable, 157
line plot, 156





















